Help Support Ram Forum by donating:


This ones weird.....

Discussion in 'Audio & Electronics' started by John Wiles, Oct 12, 2019 at 2:10 PM.

  1. John Wiles

    John Wiles Junior Member

    Age:
    60
    Posts:
    11
    Likes Received:
    1
    Joined:
    Feb 9, 2019
    Location:
    Oklahoma
    Ram Year:
    2014
    Engine:
    Cummins
    RAM 2500 Diesel 2016 model tradesman. Running great. Get in and everything dashwise is dead. When door is open, odometer displays, but with key in, no EVIC no RADIO, no crank. OBD won't read because it thinks the key is not in the on position. New batteries, voltage 13.8. Checked fuses and relays. It's like there is no power to the BCM or PCM or whatever ?cm controls those items. Maybe there is a fuse or relay somewhere? Any help or ideas appreciated. Thanks
     
  2. Elevated 2013

    Elevated 2013 Senior Member

    Age:
    44
    Posts:
    439
    Likes Received:
    265
    Joined:
    Feb 24, 2019
    Location:
    Huntley, IL
    Ram Year:
    2013
    Engine:
    5.7L Hemi
    Almost sounds like a dead BCM except for the fact that the odometer shows. I’d definitely check the grounds and if you have an alarm might want to check that as well. Possibly try to disable it. Does the key fob work to lock/unlock/arm/disarm the alarm. Almost like it could even be the ignition read the key wrong and disabled it like it thinks it’s being stolen.
     
  3. Jimmy07

    Jimmy07 Senior Member

    Posts:
    1,768
    Likes Received:
    1,182
    Joined:
    Feb 23, 2017
    Ram Year:
    2017
    Engine:
    6.4 Hemi
    When you try the fob in the ignition, does a red dot light illuminate or flash in the lower right side of the cluster.
     
  4. John Wiles

    John Wiles Junior Member

    Age:
    60
    Posts:
    11
    Likes Received:
    1
    Joined:
    Feb 9, 2019
    Location:
    Oklahoma
    Ram Year:
    2014
    Engine:
    Cummins
    Yes the fob will lock unlock Did not see the red security light. Putting key in the ignition lights the instrument cluster. It seems to reset every 15 seconds. When the key is in the ignition and the door is open it does not chime. Do you think this could be the ignition node(module/switch)????
     
  5. Elevated 2013

    Elevated 2013 Senior Member

    Age:
    44
    Posts:
    439
    Likes Received:
    265
    Joined:
    Feb 24, 2019
    Location:
    Huntley, IL
    Ram Year:
    2013
    Engine:
    5.7L Hemi
    It’s possible but that shouldn’t have anything to do with the EVIC or radio so I wouldn’t single that out. Seems like there’s a relay that isn’t powering everything else. Try disconnecting the battery positive and turn your headlights on and wait 10 minutes. Then go back out and reconnect the battery cable and then start the truck or if the symptoms change.
     
  6. John Wiles

    John Wiles Junior Member

    Age:
    60
    Posts:
    11
    Likes Received:
    1
    Joined:
    Feb 9, 2019
    Location:
    Oklahoma
    Ram Year:
    2014
    Engine:
    Cummins
    No red light
     
  7. John Wiles

    John Wiles Junior Member

    Age:
    60
    Posts:
    11
    Likes Received:
    1
    Joined:
    Feb 9, 2019
    Location:
    Oklahoma
    Ram Year:
    2014
    Engine:
    Cummins
    . First thing I tried after checking the fuses was to remove ground for about an hour. I also moved relays from a working truck to just test. No luck. It’s like the key doesn’t turn anything on when in the run position
     
  8. Elevated 2013

    Elevated 2013 Senior Member

    Age:
    44
    Posts:
    439
    Likes Received:
    265
    Joined:
    Feb 24, 2019
    Location:
    Huntley, IL
    Ram Year:
    2013
    Engine:
    5.7L Hemi
    Nothing in the acc position either I assume?? If not then the ignition module in the steering column would be a good first part to replace especially since the immobilized light didn’t come on.
     
  9. John Wiles

    John Wiles Junior Member

    Age:
    60
    Posts:
    11
    Likes Received:
    1
    Joined:
    Feb 9, 2019
    Location:
    Oklahoma
    Ram Year:
    2014
    Engine:
    Cummins
    No nothing in ACC either. Is replacing the wireless ignition node a dealer job?
     
  10. Jimmy07

    Jimmy07 Senior Member

    Posts:
    1,768
    Likes Received:
    1,182
    Joined:
    Feb 23, 2017
    Ram Year:
    2017
    Engine:
    6.4 Hemi
    You don’t have a wireless ignition node, it’s an rf hub, but yes, it would be a dealer job...IF that’s even your issue.
     

Share This Page