Worried

Discussion in 'Dodge Ram Eco Diesels' started by sdimond, Jan 9, 2019.

  1. sdimond

    sdimond Junior Member

    Age:
    49
    Posts:
    2
    Likes Received:
    1
    Joined:
    Jan 9, 2019
    Location:
    South Dakota
    Ram Year:
    2016
    Engine:
    ecodiesel
    I have a 2016 Ecodiesel with 45k miles on it bought the extended warranty as well. Was driving in the black hills on Sunday pulling a very small trailer probably around 800lbs, we had just passed a small town about 3 or 4 miles back in the middle of nowhere driving about 35mpg little snow on the ground and snowing but nothing bad at all, when all of the sudden the engine reved up very high like it went out of gear. The dashboard reads Service 4x4 do not shift into park or shut the engine off and drive to an authorized dealer for repair. I had let off the gas and it came to a stop still in gear and holding the brake. I left off the brake gave it a little gas and it went about 15 feet did the same thing reved up high and would not go. We did this 3 or 4 times until finally the truck shut down completely and then the dash started reading Service Transmission, Service ETC, Service Brakes, Service Airbags, Service Engine and so on it was saying service everything. At this point it will not come out of gear and obviously will not start so there we sit. We finally had someone stop as there was zero reception and they called a tow truck that took 2 hours to find us. So my truck sits at the dealer for a week before they have time to look at it, now it's in the 3rd day of them looking at it and they tell me they have no clue of what's wrong with it. They said it had 53 codes when they put it on the computer and have not fixed a thing yet. Any ideas or suggestions. They still can't get it out of gear it will only roll the windows up and down and that's about it. Thanks for any help.
     
    Last edited: Jan 9, 2019
    JFighterCrew likes this.
  2. kad

    kad Senior Member

    Posts:
    1,384
    Likes Received:
    908
    Joined:
    Jul 10, 2017
    Location:
    Hudson Valley Region, NY
    Ram Year:
    2014
    Engine:
    5.7L HEMI
    Well, this is by no means definitive, but it sounds like a PCM* problem to me. The first thing I would check for is critter or terrain damage to the wiring harness that goes to it. Also, while terrain damage to the wiring at the TIPM** isn't likely, critter damage is, so I would check that area as well.

    -K


    * PCM - Powertrain Control Module, aka the main computer for the engine, transmission and other drivetrain components
    ** TIPM - Totally Integrated Power Module aka Fuse/relay box
     
    JFighterCrew likes this.
  3. sdimond

    sdimond Junior Member

    Age:
    49
    Posts:
    2
    Likes Received:
    1
    Joined:
    Jan 9, 2019
    Location:
    South Dakota
    Ram Year:
    2016
    Engine:
    ecodiesel
    Well it would appear right now that they are saying the TCM is there but is not there. It is not reading on the computer at all like it's gone but obviously it is there. Now they tell me they have to file a STAR claim with Dodge on the warranty because to fix it is so expensive they need to get approval first. Anyone else heard of these kind of things.
     

Share This Page