Overnight oil pressure drop, Quick Fix!

DtheBC

Junior Member
Joined
Jul 20, 2020
Posts
21
Reaction score
43
Location
North Carolina
Ram Year
2017
Engine
5.7 Hemi
This is a big shout out to the folks on this forum. Out of the blue when going to work yesterday I noticed my oil pressure about 5 Psi lower than normal. It stayed that way even warmed up. A quick search and some reading on here and quite a few folks said change the oil filter. I did this afternoon and the oil pressure is normal again. Its weird that the night before it was normal and over night it changed. I am guessing a failed filter as theres only 2000 miles on a fluid and filter change. I have been using the Fram ultra Gold filter with good service but I am rethinking that one and gonna use WIX XP from now on. Thanks to you all!
 

Daw14

Senior Member
Joined
Nov 29, 2017
Posts
1,304
Reaction score
1,056
Ram Year
2014
Engine
5.7 hemi
This is a big shout out to the folks on this forum. Out of the blue when going to work yesterday I noticed my oil pressure about 5 Psi lower than normal. It stayed that way even warmed up. A quick search and some reading on here and quite a few folks said change the oil filter. I did this afternoon and the oil pressure is normal again. Its weird that the night before it was normal and over night it changed. I am guessing a failed filter as theres only 2000 miles on a fluid and filter change. I have been using the Fram ultra Gold filter with good service but I am rethinking that one and gonna use WIX XP from now on. Thanks to you all!
I know it’s a bit late ,but do you remember what number it was that failed . Thanks Vern.
 
OP
OP
DtheBC

DtheBC

Junior Member
Joined
Jul 20, 2020
Posts
21
Reaction score
43
Location
North Carolina
Ram Year
2017
Engine
5.7 Hemi
It was an XG10060 the gold painted filter. I have used them with No trouble for years. I cut it open and it wasnt that dirty, no metal flakes and all looked ok. It just had a problem as I am still on the same oil and the filter I put on with no issues. I dont put a lot miles on my truck. May have been a fluke, just a little disconcerting with the cost of repairs and such.
 

huntergreen

Senior Member
Military
Joined
Jan 5, 2011
Posts
11,018
Reaction score
22,914
Ram Year
2016
Engine
hemi 5.7
It was an XG10060 the gold painted filter. I have used them with No trouble for years. I cut it open and it wasnt that dirty, no metal flakes and all looked ok. It just had a problem as I am still on the same oil and the filter I put on with no issues. I dont put a lot miles on my truck. May have been a fluke, just a little disconcerting with the cost of repairs and such.
Did you check the bypass valve ?
 
OP
OP
DtheBC

DtheBC

Junior Member
Joined
Jul 20, 2020
Posts
21
Reaction score
43
Location
North Carolina
Ram Year
2017
Engine
5.7 Hemi
I did and the parts looked ok. But all that comes apart when you open the filter and if something was off kilter you couldnt tell. The anti drainback and the bypass seals were not torn. I have no Idea what happened but it had to be the filter as a new one fixed it. I have never had this happen before so no clue.
 

akvanden

Junior Member
Joined
Apr 4, 2014
Posts
20
Reaction score
1
Location
Rochester
Ram Year
2010 Laramie 1500 4WD
Engine
Hemi 5.7
Same thing happened to me yesterday on my 2015. Was just starting a 300 mile trip and notice my oil PSI was down to about 45 while driving around 70mph (typically in low 50s). By end of trip PSI was down to 40 doing 70 mph! Was using same Fram Ultra filter you were - XG10060. Was 3,200 miles into oil change. Stopped at local Autozone and got their STP xl filter (no clue if any good) and changed out this morning. Was at 42 psi when I pulled into garage, went up to 55 once I changed and pulled out of garage. Clearly defective.

Think I'm changing to WIX from now on.
 

Burla

Senior Member
Military
Joined
Apr 28, 2012
Posts
20,156
Reaction score
36,012
Ram Year
2010 Hemi Reg Cab 4x4
Engine
Hemi
oil filter thread

the last 20-30 pages shows you might want to rethink that wix xp. yes it likely wont clog or stiffen up like paper filters do, but it also isnt very good at filtering. We just post the facts, your choice, gl. At 50 microns literally every filter traps that size 99% except wix xp.

51876124149_fc895001db_c-jpg.jpg
 

Burla

Senior Member
Military
Joined
Apr 28, 2012
Posts
20,156
Reaction score
36,012
Ram Year
2010 Hemi Reg Cab 4x4
Engine
Hemi
Even worse as you see smaller size particles, it doesnt filter at all, as in near zero % effective when every other filter captures most small particles.
 

sandawilliams

Senior Member
Joined
May 29, 2012
Posts
2,779
Reaction score
5,466
Location
Pueblo West, Co.
Ram Year
2021
Engine
6.4 hemi
Same thing happened to me yesterday on my 2015. Was just starting a 300 mile trip and notice my oil PSI was down to about 45 while driving around 70mph (typically in low 50s). By end of trip PSI was down to 40 doing 70 mph! Was using same Fram Ultra filter you were - XG10060. Was 3,200 miles into oil change. Stopped at local Autozone and got their STP xl filter (no clue if any good) and changed out this morning. Was at 42 psi when I pulled into garage, went up to 55 once I changed and pulled out of garage. Clearly defective.

Think I'm changing to WIX from now on.
Wix let me down today. I am in upper Washington state with the camper. I needed an oil change and being in a remote area I purchased the materials 200 miles away, took them to a small town and had a local shop change the oil. The wix filter I bought could not be screwed onto the truck. Close inspection showed the factory threads were bad and filter could not be used. No more wix for me. I called the company customer service and they acted pissed off because I would bother them with such a trivial problem.
 
Top