INFO - 2013-2018 8.4A /AN FW Notes (RA3/VP3-NA & RA4/VP4-NA & UAx)

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

OP
OP
Mpgrimm2

Mpgrimm2

Senior Member
Preferred Vendor
Military
Joined
Mar 30, 2014
Posts
6,119
Reaction score
4,216
Location
SC
Ram Year
2022 Ram 1500 (5th Gen)
Engine
5.7L
I do have factory navigation. Everything is as it came from the factory. Are the updates at the start of this thread for the 40.1? Also, attached is the software and application version of my truck. Can I go straight to 40.1 or do I have to upgrade to an earlier version first? Thanks for your help!

View attachment 530099
No, you can't go straight to v40.1.

See the OP and this post in @clearlystable 's thread...
 

SitKneelBend

Senior Member
Military
Joined
Jan 8, 2015
Posts
9,269
Reaction score
5,047
Location
St. Louis
Ram Year
2014
Engine
3.6 Pentastar
I do have factory navigation. Everything is as it came from the factory. Are the updates at the start of this thread for the 40.1? Also, attached is the software and application version of my truck. Can I go straight to 40.1 or do I have to upgrade to an earlier version first? Thanks for your help!

View attachment 530099
Your firmware is too old to go straight to 40.1 you'll need to start with 22.6. Start with that and send me a PM once you're successful with the 22.6 (located in post 8 of this thread, you want the v22.6 UAQ firmware download link).
 

Goodmo

Junior Member
Joined
May 12, 2023
Posts
4
Reaction score
0
Location
Chatlotte
Ram Year
2018
Engine
6.7
Hello to everyone. Looking for 19.9 version for uconnect uaq. Here in first posts information but no link to download. Maybe someone can share link, thank you.

Ps I had 16.11 and did update for 18.14 uaq radio. But when I trying to put 21.9 or 22 update after 2 min radio reboots and start flashing from 90% goes up to 96 and then reboots and never pick update.

Upd 2 for 21.9 and 22 version start shows update can not be installed. Extremely need 19.9 version.
 
Last edited:

HighShyGuy

Member
Supporting Member
Joined
May 14, 2022
Posts
68
Reaction score
28
Location
Seattle, WA
Ram Year
2018
Engine
6.7L Cummins
I have a 2018 2500 tradesman with the UAQ 68331631 radio, radio was on v39.6
- I used Mike's harnesses to install, etc.

I just updated to the v40.1 with no issues, took about 25 minutes.

I was hoping my heated seats would show up in the radio, but no dice... Just the heated steering wheel still.
My tradesman received heated/cooled leather seats from a 1500 and I used Mikes harness, which works fantastic with the hard buttons.

So, no issues with my 68331631 updating from 39.6 to 40.1

Thanks again Mike!
 

mohd_arch60

Junior Member
Joined
Nov 8, 2023
Posts
2
Reaction score
0
Location
Bahrain

@Mpgrimm2
Thanks for that effort, I have a quick question if I can use those firmwares you posted earlier on CHANLLENGER R/T 2016 as my current firmware is 15.30.2 and the dealer here has no clue at all.​

 
OP
OP
Mpgrimm2

Mpgrimm2

Senior Member
Preferred Vendor
Military
Joined
Mar 30, 2014
Posts
6,119
Reaction score
4,216
Location
SC
Ram Year
2022 Ram 1500 (5th Gen)
Engine
5.7L
I don't believe the 13-17 Harmon radio fw is interchangeable between vehicle lines as they have different PNs from the RAM truck versions.

Your dealer should be able to get the v17.xx.x fw for a factory installed Challenger 8.4 radio using your VIN (again, if factory installed), then they should be able to install the 18.45.x update (or you can). If they can't, try another dealer.

If you've installed a Tazer or some sort of jailbreak fw on the radio to get Performance/SRT Pages , then you need to undo that before the updates or it may brick the radio, which can still happen
 

Kinovo

Junior Member
Joined
Nov 1, 2023
Posts
3
Reaction score
0
Location
South Carolina
Ram Year
2015
Engine
Hemi 5.7
Hello everyone, I just did the ra2 to ra4 conversion about a week ago and the radio feels a little sluggish sometimes and I am wondering if I should to update it to newer version

I have a 68238619AG ra4 from a 2015 jeep grand cherokee with 18.11.07 version

If anyone could point me in the direction to where I can get the software version I would need and how to install it that would be awesome, thanks in advance!
 

SitKneelBend

Senior Member
Military
Joined
Jan 8, 2015
Posts
9,269
Reaction score
5,047
Location
St. Louis
Ram Year
2014
Engine
3.6 Pentastar
Hello everyone, I just did the ra2 to ra4 conversion about a week ago and the radio feels a little sluggish sometimes and I am wondering if I should to update it to newer version

I have a 68238619AG ra4 from a 2015 jeep grand cherokee with 18.11.07 version

If anyone could point me in the direction to where I can get the software version I would need and how to install it that would be awesome, thanks in advance!
When it feels sluggish does it also feel hot to the touch? I had an RA4 that would be too hot to touch on the back and excessive heat would cause poor performance.
 

Site-r

Senior Member
Military
Joined
May 5, 2019
Posts
124
Reaction score
46
Location
Lynnwood, Washington
Ram Year
2017 2500
Engine
Cummings 6.7
Here is a shoutout to SitKneelBend.
I had just purchased my 2017 2500 when this thread began.
I decided to take the leap, and bought a Uaq off of EBay, and bought the wiring adapter for the Apple car play media hub from Mpgrimm2. The install went well, and then I checked to see if I needed to update the software. There were many recommendations to not update unless there was a problem, as many back then were bricking their radios.
Fast forward to 2023, and the software was already up to 40.1.
I saw that the ATT problems were fixed in this release, and contacted SetKneelBend to help me with the updates.
When I tried to get the 21.9 map release, I could not unzip it. He told me WINRAR would unzip it. He recommended using 32gb usb sticks formatted to Fat32. He also verified that you copy the VP4R_Update folder to the main directory on the stick (and map_package if loading maps).
So I started loading the 22.6 update. Next I added the map folder from 21.9 to the 28.3 update and it also loaded flawlessly. I found that the 30.24 release also had a map folder, so I loaded it next. Finally, I loaded the 40.1 release. Now with SetKneelBend’s help my radio is current.
BTW, I put a battery charger on the battery to ensure I would not run it down during the installs.
Now I can pay the help forward by helping another Ram owner who is near me.
 
Last edited:

SitKneelBend

Senior Member
Military
Joined
Jan 8, 2015
Posts
9,269
Reaction score
5,047
Location
St. Louis
Ram Year
2014
Engine
3.6 Pentastar
Here is a shoutout to SitKneelBend.
I had just purchased my 2017 2500 when this thread began.
I decided to take the leap, and bought a Uaq off of EBay, and bought the wiring adapter for the Apple car play media hub from Mpgrimm2. The install went well, and then I checked to see if I needed to update the software. There were many recommendations to not update unless there was a problem, as many back then were bricking their radios.
Fast forward to 2023, and the software was already up to 40.1.
I saw that the ATT problems were fixed in this release, and contacted SetKneelBend to help me with the updates.
When I tried to get the 21.9 map release, I could not unzip it. He told me WINRAR would unzip it. He recommended using 32gb usb sticks formatted to Fat32. He also verified that you copy the VP4R_Update folder to the main directory on the stick (and map_package if loading maps).
So I started loading the 22.6 update. Next I added the map folder from 21.9 to the 28.3 update and it also loaded flawlessly. I found that the 30.24 release also a map folder, so I loaded it next. Finally, I loaded the 40.1 release. Now with SetKneelBend’s help my radio is current.
BTW, I put a battery charger on the battery to ensure I would not run it down during the installs.
Now I can pay the help forward by helping another Ram owner who is near me.
Thanks but @Mpgrimm2 taught me everything I know!
 

Kinovo

Junior Member
Joined
Nov 1, 2023
Posts
3
Reaction score
0
Location
South Carolina
Ram Year
2015
Engine
Hemi 5.7
When it feels sluggish does it also feel hot to the touch? I had an RA4 that would be too hot to touch on the back and excessive heat would cause poor performance.
Looked at it today and it feels warm but not burning hot, do you think a factory reset would do the trick? it still has everything the previous owner had on it
 

SitKneelBend

Senior Member
Military
Joined
Jan 8, 2015
Posts
9,269
Reaction score
5,047
Location
St. Louis
Ram Year
2014
Engine
3.6 Pentastar
Looked at it today and it feels warm but not burning hot, do you think a factory reset would do the trick? it still has everything the previous owner had on it
It couldn't hurt to do a reset. If it is overheating, most of the heat will be coming off the back of the radio.
 

mohd_arch60

Junior Member
Joined
Nov 8, 2023
Posts
2
Reaction score
0
Location
Bahrain
I don't believe the 13-17 Harmon radio fw is interchangeable between vehicle lines as they have different PNs from the RAM truck versions.

Your dealer should be able to get the v17.xx.x fw for a factory installed Challenger 8.4 radio using your VIN (again, if factory installed), then they should be able to install the 18.45.x update (or you can). If they can't, try another dealer.

If you've installed a Tazer or some sort of jailbreak fw on the radio to get Performance/SRT Pages , then you need to undo that before the updates or it may brick the radio, which can still happen


I tried updating it and got that error

System market mismatch, stick contains NA but target is RW. Please remove USB stick to reset.

Is there any solution to that ?
 
OP
OP
Mpgrimm2

Mpgrimm2

Senior Member
Preferred Vendor
Military
Joined
Mar 30, 2014
Posts
6,119
Reaction score
4,216
Location
SC
Ram Year
2022 Ram 1500 (5th Gen)
Engine
5.7L
I tried updating it and got that error

System market mismatch, stick contains NA but target is RW. Please remove USB stick to reset.

Is there any solution to that ?
You have a foreign market (RoW = Rest of the world) radio and as such you need a very specific update for your year/model radio, your vehicle line, and for correct country. ... USA & Canada & Mexico, etc fw will not work. Customtronix may be able to assist you if you can't get a foreign market dealer to assist.
 

dkokochak

Junior Member
Joined
Dec 3, 2023
Posts
2
Reaction score
0
Location
33618
Ram Year
2018
Engine
6.7L
I have a 2018 Ram and the GPS stopped working after the OTA update of my software version to 17.43.44 I cant find any software updates post 17.43.44 or get a copy of it to re-install to see if it fixes it. Can any one help direct me to the file to manually install a update or fix? PN 68331631AE and App Version USA-IR-19.9.0-20171026-107G
TIA

Doing a manual update to app version 21.9 and got into a do loop, update error code 20 and reinstall previous version and stops at ~26%, then tries to update again. Whet thru about 4 or five cycles, now it is stuck on re-install screen and not installing anything. Is this Bricked? and can it be recovered?
 
Last edited:

myckee

Junior Member
Joined
Feb 21, 2024
Posts
8
Reaction score
6
Location
Canada
Ram Year
2016
Engine
Hemi
I registered just to add my info to this awesome thread. I have a 2016 Cherokee Limited with a Canadian VP4. I found another Canadian VP4 in a 2015 Cherokee Limited at the junkyard. Part number 68238626AG. I bought the radio, found an online place to get the anti-theft code for $10 and put it in my Jeep. It works and unlocked. Software was at 15.06.1. I downloaded the 17.11.07 for 2015 from post #4 in this thread. Currently updating as we speak! Once it is finished, and successful, I will try the 18.45.01 update.

EDIT: 17.11.07 was successful in the 2015 Canadian VP4 and the part number went from AG to AJ -> 68238626AJ. Will try 18.45.01 now.

Edit2: 18.45.01 was successful in the 2015 Canadian VP4 and the part number went from AJ to AL -> 68238626AL

Next I will try updating the original 2016 Canadian VP4 next using the files from Post #5.

Thank you to all who have contributed and Mpgrimm2 for the great thread and files.
 
Last edited:

myckee

Junior Member
Joined
Feb 21, 2024
Posts
8
Reaction score
6
Location
Canada
Ram Year
2016
Engine
Hemi
Okay after the success I had updating the 2015 Canadian VP4 from the junkyard, I had the confidence to try updating the original 2016 Canadian VP4, 15.30.6, 68258675AH that came in my Jeep. I followed the same upgrade steps I did with the 2015 above.

17.11.07 was successful in the 2016 Canadian VP4 and the part number went from AH to AI -> 68258675AI. Will try 18.45.01 now.

Edit: 18.45.01 was successful in the 2016 Canadian VP4 and the part number went from AI to AJ -> 68258675AJ

Thanks again to Mpgrimm2 for the great thread and files and thank you to all who have contributed.
 
Last edited:

Ashton

Senior Member
Joined
Feb 20, 2019
Posts
113
Reaction score
69
Location
VA
Ram Year
'18
Engine
Hemi
I have a 2018 Ram and the GPS stopped working after the OTA update of my software version to 17.43.44 I cant find any software updates post 17.43.44 or get a copy of it to re-install to see if it fixes it. Can any one help direct me to the file to manually install a update or fix? PN 68331631AE and App Version USA-IR-19.9.0-20171026-107G
TIA

Doing a manual update to app version 21.9 and got into a do loop, update error code 20 and reinstall previous version and stops at ~26%, then tries to update again. Whet thru about 4 or five cycles, now it is stuck on re-install screen and not installing anything. Is this Bricked? and can it be recovered?
I'm in the same boat, gps has me floating like 2 or 3 states away since November 2019. I'm stuck on 17.43.44 as well. Could someone share the update file? Only difference for me is my truck is originally Canadian. Thanks
 
OP
OP
Mpgrimm2

Mpgrimm2

Senior Member
Preferred Vendor
Military
Joined
Mar 30, 2014
Posts
6,119
Reaction score
4,216
Location
SC
Ram Year
2022 Ram 1500 (5th Gen)
Engine
5.7L
I'm in the same boat, gps has me floating like 2 or 3 states away since November 2019. I'm stuck on 17.43.44 as well. Could someone share the update file? Only difference for me is my truck is originally Canadian. Thanks

From the first post...

FYI. The latest v18.45.01 update for ALL 13-17 Ra3 VP3-NA and RA4 VP4-NA radios (& Canada) is in a separate thread at the moment & requires SW version 17.11.x or higher **
ROLL-UP INFO: FOTA 18.11.x & uC D/L 18.45.01 SW Update 13-17 RA3/Vp3-NA & Ra4 VP4-NA.
 

Latest posts

Forum statistics

Threads
196,967
Posts
2,888,591
Members
158,636
Latest member
aley
Top